We now support 1.16!

AppleMacOS

Administrator
Staff member
Admin
Mod
VIP
Dec 11, 2019
6
4
3
Hello everyone!

As you probably know Minecraft 1.16 just came out, and we already support it! You can read more about the update here.

That means we now support these versions: 1.8.x, 1.9.x, 1.10.x, 1.11.x, 1.12.x, 1.13.x, 1.14.x, 1.15.x and 1.16!

If you encounter any bugs when using 1.16 on the server please report them on the forums here, or make a ticket on the Discord Server.

However we still recommend using 1.8.9 for Duels and 1.12.2 for IslandPlot, and SkyBlock when it comes out 😉

Thanks for reading!
 
  • Like
Reactions: Ri_210